Issues viewing or uploading files
Incident Report for Notion
Resolved
This incident has been resolved.
Posted Aug 10, 2022 - 00:08 PDT
Investigating
We are currently investigating the issue.
Posted Aug 09, 2022 - 21:21 PDT
This incident affected: Notion App.