Issue creating and editing pages
Incident Report for Notion
Resolved
We have rolled out a fix to resolve this issue. If your app still shows "Saving…", please copy any recently added text to another application and reload the page.
Posted Sep 30, 2024 - 17:32 PDT
Investigating
Some users are experiencing issues creating and editing pages. We have identified the issue, and our engineering team is actively fixing the issue.
Posted Sep 30, 2024 - 17:27 PDT
This incident affected: Notion App and View and edit content.