Guest Access Issues

Incident Report for Notion

Resolved

Our team has deployed the fix and now the system is fully operational.
Posted Dec 09, 2024 - 00:18 PST

Identified

We have identified the root cause and working on a fix. We will provide more updates as and when they become available.
Posted Dec 08, 2024 - 22:25 PST

Investigating

Some Notion guests are currently experiencing issues accessing pages. Our engineering team has been notified and is actively working to resolve this issue. We will provide updates as soon as they become available.
Posted Dec 08, 2024 - 19:51 PST
This incident affected: View and edit content.