Users on the Free plan may experience issues uploading files to Notion.

Incident Report for Notion

Resolved

This incident has now been resolved and this issue should no longer be occurring.
Posted Jan 24, 2025 - 18:01 PST

Investigating

We are currently investigating an issue where users on our Free plan may experience an issue uploading a file to Notion pages. Files below the 5MB threshold may trigger the 5MB limit regardless of size.
Posted Jan 24, 2025 - 17:26 PST
This incident affected: Notion App.