Degraded performance for some workspaces
Incident Report for Notion
Resolved
This issue has been resolved.
Posted Sep 17, 2021 - 13:10 PDT
Update
The fix is still being deployed. Most users should be experiencing better performance.
Posted Sep 17, 2021 - 08:44 PDT
Identified
The issue has been identified. A fix is being implemented and some users may be experiencing better performance.
Posted Sep 16, 2021 - 11:39 PDT
Investigating
Notion is experiencing an issue that causes renamed database properties to affect filters incorrectly, causing performance issues for some workspaces. We’re investigating and will post further updates.
Posted Sep 03, 2021 - 11:45 PDT
This incident affected: Notion Application.