Sites published to custom domains receiving 404 errors
Incident Report for Notion
Resolved
This incident has been resolved.
Posted Feb 13, 2025 - 15:47 PST
Investigating
We are currently investigating this issue.
Posted Feb 13, 2025 - 14:58 PST
This incident affected: Notion App.