Blocked by internet service providers
Incident Report for Notion
Resolved
This issue has been resolved.
Posted Apr 13, 2021 - 19:37 PDT
Investigating
Notion is being blocked by certain internet service providers — some users may have trouble connecting to the service. We are investigating the issue and will continue to post updates.
Posted Apr 13, 2021 - 14:40 PDT
This incident affected: Notion App.