Performance degradation
Incident Report for Notion
Resolved
This issue has been resolved. Users should be able to successfully load Notion pages now.
Posted Mar 17, 2023 - 13:36 PDT
Update
We are continuing to work on mitigation and resolution for slow loading times.
Posted Mar 17, 2023 - 12:13 PDT
Identified
Some users are experiencing slow load times. We have identified the root cause and are working on resolving it.
Posted Mar 17, 2023 - 10:52 PDT
This incident affected: Notion App and Notion API.