Issue persisting edits
Incident Report for Notion
Resolved
We have fixed the issue. Users who encounter the error can resolve it by reloading the app or browser.
Posted Feb 16, 2022 - 14:45 PST
Identified
Some users are receiving the error “There was an issue persisting your edits.” We have identified the issue and are working on a fix.
Posted Feb 16, 2022 - 14:31 PST
This incident affected: Notion Application.