Elevated Latency for Large Databases
Incident Report for Notion
Resolved
This incident has now been resolved and latency should now return to normal.
Posted Nov 19, 2024 - 03:41 PST
Investigating
We are currently experiencing some elevated latency for large databases and our engineering team is on it!
Posted Nov 19, 2024 - 01:54 PST
This incident affected: Databases.