Errors updating Notion subscription
Incident Report for Notion
Resolved
On February 15th 2023 between 01:39 PST - 08:43 PST, Notion was experiencing an issue with subscription updates, which may have resulted in errors when changing billing plans.

Our engineering team identified the issue and increased capacity to this service to prevent errors, and this is now working as normal. We appreciate your patience and will work to prevent similar errors in future.
Posted Feb 15, 2024 - 09:30 PST
Investigating
Customers may experience an error when attempting to change their Notion subscription.
Our team is investigating the root cause now and we will share updates as soon as possible.
Posted Feb 15, 2024 - 08:52 PST
This incident affected: Administration.