Notion App Degraded Performance for Guests
Incident Report for Notion
Resolved
The issue has now been resolved. Guests will no longer experience issues with uploading large files, page history or custom automations.
Posted Sep 27, 2024 - 16:35 PDT
Identified
Notion is currently experiencing degraded performance and certain features may be inaccessible for guests. Guests may experience issues with uploading large files, page history or custom automations.

We have identified the issue and our engineering team is rolling out a fix for the issue.
Posted Sep 27, 2024 - 13:52 PDT
This incident affected: Notion App.