Issue with web app
Incident Report for Notion
Resolved
From 2:28–2:37pm PST, users were not able to log in or open pages via https://notion.so. Desktop and mobile app users were not affected.
Posted Feb 22, 2021 - 14:30 PST