Notion Calendar Errors and Delays
Incident Report for Notion
Resolved
On March 20, 2024 between 11:00pm PDT and March 21, 2024 at 07:51am PDT, we experienced a problem with Notion Calendar which led to reduced performance and errors for end users.
Our engineering team identified the problem and applied a fix to resolve this and restore the service to a regular working state.
We’ll continue investigating the root cause and work to prevent recurrence, and we apologize for the inconvenience.
Posted Mar 21, 2024 - 08:57 PDT
Monitoring
Our team has implemented a fix for this issue and we're seeing an improvement to calendar performance as a result. We will monitor this to ensure there is no further impact and confirm as soon as possible that the underlying problem is fully resolved.

Thank you for your patience while we work through this.
Posted Mar 21, 2024 - 07:39 PDT
Investigating
Customers may experience errors and delays with Notion Calendar at present.

Our team is investigating the issue and will share updates as soon as possible as we work to resolve this problem.
Posted Mar 21, 2024 - 06:16 PDT
This incident affected: Notion Calendar.