Issues loading databases

Incident Report for Notion

Resolved

This incident has been resolved.
Posted Dec 06, 2024 - 09:42 PST

Investigating

Some users may have experienced issues with loading databases over the past hour. Our engineers have mitigated the issue and are investigating the root cause to prevent future occurrences. We will share an update as soon as we can.
Posted Dec 06, 2024 - 08:17 PST
This incident affected: Databases.