Some users may experience issues loading database pages
Incident Report for Notion
Resolved
Our engineers have resolved this issue now and users should no longer have issues loading database pages caused by this incident. If you are continuing to experience issues loading databases or pages within them, please reach out to team@makenotion.com from the email on your account or choose the option in Notion to send us a message and we can take a closer look.
Posted Nov 20, 2024 - 06:32 PST
Investigating
Some users may see errors (e.g. 500, "Oops there was an error loading this page. Refresh to load it again") loading specific pages in databases with. Our engineers are investigating this currently.
Posted Nov 20, 2024 - 06:06 PST
This incident affected: Databases.