Guests facing issues tagging members on pages

Incident Report for Notion

Resolved

This incident has been resolved.
Posted 2 months ago. Dec 17, 2024 - 23:01 PST

Investigating

We are currently investigating this issue
Posted 2 months ago. Dec 17, 2024 - 01:25 PST
This incident affected: Notion App, Databases, and View and edit content.