Sep 24 2023 Notion is down
Incident Report for Notion
Resolved
The issue has been resolved, and notion.so is available to all users.
Posted Sep 24, 2023 - 18:04 PDT
Update
The issue has been resolved, and notion.so is available to all users.
Posted Sep 24, 2023 - 18:03 PDT
Investigating
Notion.so is currently down for some users. We are actively investigating.
Posted Sep 24, 2023 - 17:56 PDT
This incident affected: Notion App.