Some users may experience some slowness
Incident Report for Notion
Resolved
The issue has now been resolved and users should be able to use Notion as normal.
Posted Jun 17, 2024 - 21:13 PDT
Update
We are continuing to investigate this issue.
Posted Jun 17, 2024 - 21:08 PDT
Investigating
Some users may experience some slowness with some performance issue, we are investigating into it. we will share updates as soon as possible
Posted Jun 17, 2024 - 20:44 PDT
This incident affected: View and edit content.