Relations degraded performance
Incident Report for Notion
Resolved
This incident is resolved for all customers.
Posted Jul 26, 2023 - 17:22 PDT
Investigating
We are currently investigating an issue with relations experiencing degraded performance
Posted Jul 26, 2023 - 12:39 PDT
This incident affected: Notion App.