Users may encounter errors when submitting forms on public sites.

Incident Report for Notion

Resolved

This incident has been resolved and users should be able to submit public forms.
Posted 1 month ago. Jan 26, 2025 - 20:04 PST

Update

We have identified the root cause and working on a fix. We will provide more updates as and when they become available.
Posted 1 month ago. Jan 26, 2025 - 19:24 PST

Investigating

Users may encounter errors when submitting forms on public sites.
We are currently investigating this issue.
Posted 1 month ago. Jan 26, 2025 - 18:49 PST