Notion is experiencing degraded performance
Incident Report for Notion
Resolved
The issue has been resolved. Notion app and API performance is back to Normal.
Posted Oct 02, 2023 - 17:13 PDT
Identified
We are experiencing some performance degradation and are investigating the cause.
Posted Oct 02, 2023 - 16:54 PDT
This incident affected: Notion App and Notion API.