Issue accessing Workspace Analytics

Incident Report for Notion

Resolved

We have rolled out a fix to resolve this issue. Workspace Owners on Enterprise plans should now be able to load Workspace Analytics.
Posted Sep 23, 2024 - 14:00 PDT

Identified

We have identified the issue and our engineering team is rolling out a fix for the issue.
Posted Sep 23, 2024 - 13:02 PDT

Investigating

Workspace Owners on our Enterprise plan may experience issues loading Workspace Analytics. We are currently investigating and will share updates as soon as possible.
Posted Sep 23, 2024 - 07:52 PDT
This incident affected: Administration.