Notion is experiencing service degradation related to notifications
Incident Report for Notion
Resolved
Notification health should be back to normal. Engineering will continue to monitor system health.
Posted Oct 17, 2023 - 11:59 PDT
Investigating
We are experiencing service degradation related to notifications. Notifications may be delayed, and notification badge counts may not be accurate.
Posted Oct 17, 2023 - 11:40 PDT
This incident affected: Notion App.