High latency performing certain operations
Incident Report for Notion
Resolved
We have resolved the issue. All import, export and duplication work as expected.
Posted Oct 21, 2022 - 11:31 PDT
Identified
We have implemented a partial fix to unblock key functions, and users should see significant improvement in import, export, and duplication times. We continue to work toward full resolution.
Posted Oct 21, 2022 - 09:39 PDT
Investigating
Some customers may be experiencing high latency when attempting to export or import content, or duplicate blocks or pages. We are investigating.
Posted Oct 21, 2022 - 08:21 PDT
This incident affected: Notion App.