Unable to view Member's list via the Settings

Incident Report for Notion

Resolved

Our engineering team has rolled out a fix for this and the issue has been resolved now.
Posted Feb 26, 2025 - 23:14 PST

Investigating

We are currently experiencing an issue where some users may not be able to see the full list of their member list in the settings. Our engineering team is investigating the issue.
Posted Feb 26, 2025 - 22:43 PST
This incident affected: Administration.