Blocked by ISPs
Incident Report for Notion
Resolved
This incident has been resolved.
Posted Jan 21, 2021 - 19:41 PST
Investigating
Notion is being blocked by certain internet service providers — some users may have trouble connecting to the service. We are investigating the issue and will continue to post updates.
Posted Jan 21, 2021 - 16:08 PST
This incident affected: Notion Application.