Database Automation Degradation in Notion

Incident Report for Notion

Resolved

Our team has deployed a fix, and the system is now functioning as expected.
Posted Nov 25, 2024 - 04:24 PST

Update

We are continuing to investigate this issue.
Posted Nov 25, 2024 - 04:17 PST

Investigating

Notion is experiencing a degradation in Database automations, causing delays in trigger execution.
Posted Nov 25, 2024 - 04:17 PST
This incident affected: Databases.