Notion is experiencing degraded performance

Incident Report for Notion

Resolved

The issue has been resolved. Notion app and API performance is back to Normal.
Posted Oct 02, 2023 - 16:03 PDT

Update

We're continuing to monitor the impact of the fix we implemented. We expect it may take a few hours to fully complete.
Posted Oct 02, 2023 - 14:28 PDT

Monitoring

We're rolling out a fix and will continue monitoring.
Posted Oct 02, 2023 - 13:54 PDT

Update

We have developed a fix and will be implementing soon.
Posted Oct 02, 2023 - 13:02 PDT

Identified

We have identified the issue and are working on a fix.
Posted Oct 02, 2023 - 06:40 PDT

Investigating

We are experiencing some performance degradation and are investigating the cause.
Posted Oct 02, 2023 - 06:24 PDT
This incident affected: Notion App and Notion API.