Degraded performance with Notion databases

Incident Report for Notion

Resolved

Our engineering team has rolled out a fix and the issue is resolved now.
Posted Feb 27, 2025 - 23:48 PST

Investigating

We are facing degraded performance in the Notion databases. Our engineering team is currently investigating the issue.
Posted Feb 27, 2025 - 23:04 PST
This incident affected: Databases.