Notion is down

Incident Report for Notion

Resolved

Notion has remained stable since the last update and we are now considering this incident resolved.
Posted 13 days ago. Feb 14, 2025 - 06:59 PST

Monitoring

Notion should now be accessible once again. Our team are monitoring this closely at present.
Posted 13 days ago. Feb 14, 2025 - 06:09 PST

Investigating

We are re-opening the incident reported earlier as we have received additional reports of Notion being inaccessible for users. Our engineers are investigating the issue at present.
Posted 13 days ago. Feb 14, 2025 - 05:55 PST
This incident affected: Notion App.