Issue impacting users in Korea
Incident Report for Notion
Resolved
This incident has been resolved.
Posted Apr 10, 2023 - 17:10 PDT
Monitoring
Impacted users should see improvements when interacting with static elements. We're still actively monitoring the issue.
Posted Apr 10, 2023 - 12:29 PDT
Investigating
We are experiencing performance issues that may impact users in Korea. Users may experience significant delays when interacting with static content, like images and videos. Engineering is investigating the root cause of the degradation.
Posted Apr 06, 2023 - 23:01 PDT
This incident affected: Notion App.