Issues accessing workspace for certain users

Incident Report for Notion

Resolved

This incident has been resolved.
Posted 17 days ago. Mar 25, 2025 - 23:20 PDT

Investigating

We're aware of an issue in product where some users may have issues accessing their workspace.
Posted 17 days ago. Mar 25, 2025 - 22:36 PDT
This incident affected: Notion App.