Performance degradation in bigger databases may cause slowness
Incident Report for Notion
Resolved
This incident has been resolved.
Posted Sep 20, 2024 - 11:30 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 20, 2024 - 10:26 PDT
Investigating
We are currently investigating this issue.
Posted Sep 20, 2024 - 10:14 PDT
This incident affected: Databases.