High latency
Incident Report for Notion
Resolved
We have confirmed this issue has been resolved, and Notion should load normally for all users.
Posted Mar 27, 2023 - 08:53 PDT
Monitoring
We have implemented a fix that has restored normal loading times for most users, and are continuing to monitor.
Posted Mar 27, 2023 - 08:42 PDT
Investigating
Notion is loading slowly or not at all for some users. We are investigating.
Posted Mar 27, 2023 - 07:40 PDT
This incident affected: Notion App and Notion API.