Database Latency Issues
Incident Report for Notion
Resolved
This incident has now been resolved.
Posted Oct 30, 2024 - 09:18 PDT
Investigating
We are currently investigating an issue with database latency. Notion users may experience increased loading times for databases.
Posted Oct 30, 2024 - 08:45 PDT
This incident affected: Databases.