Page snapshots
Incident Report for Notion
Resolved
This incident has been resolved.
Posted Apr 07, 2021 - 17:53 PDT
Identified
Some users are encountering issues when viewing recent snapshots in the Page History tool. We have identified the issue and are working on a fix.
Posted Apr 07, 2021 - 13:08 PDT
This incident affected: Notion Application.