High Notion latency
Incident Report for Notion
Resolved
Between 12:19pm and 1:00pm Pacific time some Notion users may have experienced longer loading times. This issue has been resolved.
Posted Nov 12, 2021 - 13:02 PST
Identified
Some Notion users may be experiencing longer loading times. We have identified the cause and are working on a fix.
Posted Nov 12, 2021 - 12:57 PST
This incident affected: Notion Application & API.