Users are currently unable to use the calendar. Our team is investigating the issue.

Incident Report for Notion

Resolved

The issue has now been resolved, and users are able to use the Notion Calendar.
Posted Apr 17, 2025 - 19:47 PDT

Investigating

We are currently investigating this issue.
Posted Apr 17, 2025 - 19:24 PDT
This incident affected: Notion Calendar.