Notion is experiencing degraded performance
Incident Report for Notion
Resolved
The issue has been resolved. Notion app and API performance is back to Normal.
Posted Oct 04, 2023 - 10:52 PDT
Monitoring
We've rolling out a fix and will continue monitoring.
Posted Oct 04, 2023 - 09:28 PDT
Identified
We have implemented a fix and rolling out.
Posted Oct 04, 2023 - 09:04 PDT
Investigating
We are experiencing some performance degradation and are investigating the cause.
Posted Oct 04, 2023 - 08:32 PDT
This incident affected: Notion Application and Notion API.