Some users experiencing 504's from notion.site
Incident Report for Notion
Resolved
This incident has been resolved.
Posted Sep 28, 2021 - 11:23 PDT
Update
Some users may be experiencing issues accessing notion.site websites. Our team is currently investigating.
Posted Sep 28, 2021 - 11:17 PDT
Investigating
Some users may be experiencing issues accessing notion.site websites. Our team is currently investigating.
Posted Sep 28, 2021 - 11:16 PDT
This incident affected: Notion Application.