Error editing, saving and signing in Notion
Incident Report for Notion
Resolved
Our services are now fully recovered. Our team will be continuing to investigate the cause of the issue.
Posted Mar 25, 2024 - 09:32 PDT
Update
Our engineers are seeing some improvements in the experience but the performance of our services remains degraded.

We are actively working to identify the cause of the issue and will continue providing updates as we make progress.
Posted Mar 25, 2024 - 08:43 PDT
Update
Please refrain from refreshing your pages in order for your changes to be saved when Notion recovers.

Our engineers are trying to identify the cause of this edit/save issue and are currently working on a fix. We will share additional updates as soon as we can.

In addition, some users may also be temporarily unable to log in but we are working on a fix.

Thank you for your patience.
Posted Mar 25, 2024 - 06:53 PDT
Investigating
Notion is encountering issues saving changes. Our engineering team is currently investigating this issue and we will share updates as soon as possible.
Posted Mar 25, 2024 - 05:54 PDT
This incident affected: Notion App, Login and user accounts, Databases, View and edit content, and Notion API.