Error saving pages and edits in Notion
Incident Report for Notion
Resolved
On March 22nd 2024 between 1:00AM PDT - 2:45AM PDT, Notion was experiencing a systemwide outage preventing users from saving pages and making edits. This also affected access to Notion and edits through our Public API.

Our engineering team identified an issue with a bottleneck in our server traffic which caused service degradation. We reset the affected services to resolve this issue and restore this functionality.

We are continuing to review this issue and working to prevent recurrence of this problem.
Posted Mar 22, 2024 - 03:28 PDT
Monitoring
Our engineers have reset the affected services and users can now save and edit pages in Notion as normal.

We are monitoring the situation to ensure this issue does not reoccur and will share further updates when this issue is definitively resolved.
Posted Mar 22, 2024 - 03:06 PDT
Identified
Our engineers have identified the cause of the issue and are working to restore service for all users.

We are seeing some improvements and will share more updates as soon as possible as we get closer to a full resolution.
Posted Mar 22, 2024 - 02:15 PDT
Investigating
Notion is failing to save pages and edits due to a system error. Our engineering team is fully focused on resolving the issue and we will share updates as soon as possible
Posted Mar 22, 2024 - 01:41 PDT
This incident affected: Notion App, Login and user accounts, Databases, View and edit content, and Notion API.